【Flutter/Dart】The current Dart SDK version is 2.15.1.の対処法

最終更新日

この記事では、FlutterでThe current Dart SDK version is 2.15.1.エラーが出てしまったときの対処法をまとめました。

The current Dart SDK version is 2.15.1.

Because [プロジェクト名] requires SDK version >=2.16.1 <3.0.0, version solving failed. pub get failed (1; Because [プロジェクト名] requires SDK version >=2.16.1 <3.0.0, version solving failed.)

英訳

現在のDart SDKのバージョンは2.15.1です。
プロジェクト名] は SDK バージョン >=2.16.1 <3.0.0 を必要とするので、バージョン解決に失敗しました。 pub get failed (1; [プロジェクト名] は SDK バージョン >=2.16.1 <3.0.0 を必要とするので、バージョン解決に失敗しました。)

対処法

android stadio のターミナルで

Flutter Update 

と入力してみてください。以上です。

公式サイト

https://docs.flutter.dev/development/tools/sdk/upgrading

参考サイト

fem